xcode-select - アップデートサーバーではインストールできません


6

新しいコマンドラインツールをOS X 10.9にインストールしようとしていますが、アップルからこの奇妙なエラーが出ます。

現在、ソフトウェアアップデートサーバーからソフトウェアを入手できるため、ソフトウェアをインストールできません。 xcode-select --install

screenshot

この問題を回避するには、https://developer.apple.com/downloads/index.actionここからツールをダウンロードすることです - nnyby

しかし、それはまた、エラーを返します。

screenshot

誰もがこれをダウンロードする別の方法を提供することはできますか?

+1

回避策は、ここからツールをダウンロードすることです。https://developer.apple.com/downloads/index.action#nnyby 13 11月. 13

2

サイトはもう一度オンラインになっているようです。サイトが再びオフラインになった場合\ O/

はここでダウンロードへの直接リンクです:

http://adcdownload.apple.com/Developer_Tools/command_line_tools_os_x_mavericks_for_xcode__late_october_2013/command_line_tools_os_x_mavericks_for_xcode__late_october_2013.dmg

  0

「セッションは期限切れです」というメッセージが表示されます。David Given 07 1月. 14


0
this stackoverflow answerで指摘したように

XCodeのコマンドラインツールは、Appleの開発者向けサイトhereから直接ダウンロードすることができます。

また、私がXCode CLT install/bootstrap scriptを実行すると、簡単に自動化されたソリューションを探している場合もあります。


0

このエラーは、you already have the command tools installedを意味する可能性もあります。そのエラーメッセージは、その時点までのものでした。